I just wrote a code review comment that I feel particularly smug about.
The code I was reviewing:
class PointClouds ...
My comment:
It is a bad idea to have a type name in plural. If you need to signify plurality, use a plurality-signifying suffix in singular form, as in:
- PointCloudCollection
- PointCloudSet
- PointCloudGroup
- or go creative with PointCloudFormation
- or take creativity to a whole new level with PointCumulonimbus
Anything but a plural type name.
No comments:
Post a Comment